ユーザ用ツール

サイト用ツール


ch_server

ネットワーク通信

ドリトルではサーバーを起動することで、ネットワークに接続された他のコンピュータ上のドリトルと通信することが可能になる。

サーバーの起動

サーバーはドリトルの編集画面から「server」のチェックボックスをクリックすることで起動することができる。警告のウィンドウが表示された場合には、「ブロックを解除する」を選択する。

起動すると、「server」のチェックボックスの下に枠が表示される。 サーバに情報が送られると、この枠内に内容が随時表示される。

IPアドレスの確認

ドリトルがサーバーと通信するときは、サーバーが起動しているコンピュータを指定する必要がある。ドリトルがサーバーと同じコンピュータで動作している場合は、コンピュータ名として localhost を指定することで通信できる。

ドリトルがサーバーと異なるコンピュータで動作している場合は、サーバーの動作しているコンピュータ名またはIPアドレスを指定する。ドリトルが動作しているコンピュータのIPアドレスは、サーバー画面の下部に表示されている。(「192.168.11.8」の部分はコンピュータによって異なる)

サーバーとの接続

サーバーと通信するプログラムでは、最初にサーバーとの接続を行う。次のプログラムはドリトルが動いているコンピュータで動作しているサーバーと接続する。異なるコンピュータで動作している場合には、「localhost」 の代りにサーバーが動作しているコンピュータを名前かIPアドレスで指定する。

 サーバー!"localhost" 接続。

オブジェクトの書き込み

あるコンピュータ上で作ったタートルやボタンなどの各種のオブジェクトをサーバーに登録することで、他のコンピュータに受け渡すことができる。

サーバーオブジェクトの書くという命令により、指定したオブジェクトの複製をサーバー上に名前を付けて登録できる。次のプログラムでは、「かめた」 という名前のタートルオブジェクトを、サーバーに 「kameta」 という名前で登録している。

 サーバー!"localhost" 接続。
 かめた=タートル!作る。
 サーバー!"kameta" (かめた)書く。

オブジェクトの読み出し

サーバーに書き込んだオブジェクトは、読むという命令により、読み出して利用することができる。次のプログラムでは、サーバー上に「kameta」 という名前で登録されたタートルオブジェクトを、使用中のドリトル上に複製し「かめきち」という名前を付けている。

 サーバー!"localhost" 接続。
 かめきち=サーバー!"kameta" 読む。
 かめきち!100 歩く。
ch_server.txt · 最終更新: 2018/02/09 02:05 by klab