BitArrow

BitArrow

  • Bit Arrowを使用することで、ブラウザからドリトルを利用できます。(Bit Arrowの使い方はこちら
  • PCへのインストールが不要で、手軽にドリトルを使えます。
  • 従来のドリトル(Java版)とは機能の違いがありますので、目的に応じて使い分けてください。

    画像の説明

未対応の機能(2016年8月末時点)

  • 音楽
  • ネットワーク通信
  • ロボットなどの外部機器(MYUロボ, Arduino, Leap Motion, Raspberry Pi, Studuino)

追加された機能

センサオブジェクト

  • スマートフォン・タブレット端末に搭載されたセンサを扱うことができます。
  • 端末によって扱えるセンサの種類は異なります。
  • 使用可能なセンサ類:ジャイロセンサ、タッチセンサ
    • ジャイロセンサ:端末の傾きを取得することができます。
      //端末のx, y, z軸回転の角度を取得し、表示する
      ジャイロ=ジャイロセンサ!作る。
      値表示=ラベル!作る。
      タイマー!作る  「
       x=ジャイロ!水平の傾き?。
       y=ジャイロ!左右の傾き?。
       z=ジャイロ!前後の傾き?。
       値表示!("x: " + (x) + ", y: " + (y) + ", z: " + (z))  書く。
      」実行。

テキストエリア

  • 複数行の文字列を表示・編集することができます。
  • 詳しくはマニュアルの「テキストエリア」の説明をご覧ください。
    • プログラム
      テキストエリア=テキストエリア!作る。
      テキストエリア!”かめた” 書く 改行。
      テキストエリア!”かめきち” 書く。
    • 実行結果
      画像の説明

従来のドリトル(Java版)からの変更点

タイマー

  • タイマーの実行が終るのを待ってから次の処理を行うときの書き方が変わりました。
    • 新しい書き方はJava版のドリトル(V2.39以降)でも使用できます。
  • 従来の書き方(タートルが10秒間回転した後、100歩あるきます)
    • 「待つ」で、時計の実行が終了するまで処理がプログラムの処理が止まります。
      時計=タイマー!作る。
      時計!「かめた!10 左回り」実行。
      時計!待つ。
      かめた!100 歩く。
  • 新しい書き方(タートルが20秒間回転した後、100歩あるきます)
    • 「次に実行」で、前の「実行」に続いてタイマーを実行します。
    • 「最後に実行」で、前の「実行」や「次に実行」に続いて、1回だけ実行します。
      時計=タイマー!作る。
      時計!「かめた!10 左回り」実行。
      時計!「かめた!10 左回り」次に実行。
      時計!「かめた!100 歩く」最後に実行。

その他

  • 一部のオブジェクトではプロパティの利用や継承が行われません。(数値、文字列、真偽値、配列、ブロック)

Theme designed by Dining tables
Coder Mothers Day | EZwpthemes |modified by QHM Temps

powered by Quick Homepage Maker 5.0
based on PukiWiki 1.4.7 License is GPL. QHM

最新の更新 RSS  Valid XHTML 1.0 Transitional