のんびりタートル

のんびりタートル

「タートルはかめさんらしく、ゆっくり歩いてほしいなあ」を実現する設定です。

前半の定義部分を「かんたん.ini」といったフィアルに入れておき、
後半の先頭で「システム!”かんたん” 使う。」を書くことで、この機能を使うことができます。

次のバージョン(V2.38からV2.40あたり?)で標準に入れたいと考えていますが、興味のある
人はご自分で定義して使ってみてください。

画像の説明

// ======== ここからの定義をドリトルの標準に入れる(予定) ========
// ゆっくり歩くタートルの試作
かめ=タートル!作る 消える。
かめ:あるく=「|x| タイマー!作る(x/5)回数「自分!5 歩く」実行 待つ。自分」。
かめ:ひだりにまわる=「|x| タイマー!作る(x/5)回数「自分!5 左回り」実行 待つ。自分」。

// 図形のタートル化の試作
図形:turn_center=true。
図形:向き=0。
図形:あるく=「|n| タイマー!作る(n/5)回数「自分!(5×cos(向き))(5×sin(向き))移動する」実行 待つ。自分」。
図形:ひだりにまわる=「|n| 向き=向き+n。タイマー!作る(n/5)回数「自分!(5)左回り」実行 待つ。自分」。
// ======== ここから下は生徒が書く部分 ========

// 図形がゆっくり歩く。
かめた=かめ!作る。
三角=「かめた!100 歩く 120 右回り」!3 繰り返す(青)図形を作る 150 右回り 0 50 移動する。
三角!100 あるく 90 ひだりにまわる 100 あるく。

// タートルがゆっくり歩く。
かめた!150 あるく 90 ひだりにまわる 40 あるく。

Theme designed by Dining tables
Coder Mothers Day | EZwpthemes |modified by QHM Temps

powered by Quick Homepage Maker 5.0
based on PukiWiki 1.4.7 License is GPL. QHM

最新の更新 RSS  Valid XHTML 1.0 Transitional