図形をまとめて操作(1)

図形をまとめて操作(1)

複数の図形をまとめて、ひとつの図形のように操作する機能です。

(V2.38で採用される予定です。一足早く試してみたい方はテスト版のdolittle.jarをご利用くださいfiledolittle.jar

複数の図形をパラーメーターにして図形の「結合する」メソッドを実行すると、それらの図形を結合した組図形オブジェクトが返ります。後から「書く」で図形を追加することもできます。

(例)
車=図形!(屋根)(車体)(車輪1)(車輪2)結合する。
車!(星)書く。

組図形オブジェクトでは、通常の図形と同様に「右回り、左回り、移動する、位置、塗る、消える、現れる、手前に表示、作る、拡大する」のメッソドを使えます。組図形同士を結合して新しい組図形を作ることも可能です。現在は「衝突」イベントには対応していません。

画像の説明

かめた=タートル!作る。
屋根=かめた!200 歩く 150 左回り 50 歩く 30 左回り 100 歩く 180 左回り 閉じる(緑)図形を作る。
車体=「かめた!200 歩く 90 右回り 50 歩く 90 右回り」!2 繰り返す(青)図形を作る。
車輪1=かめた!20 円(紫)図形を作る 50 −30 移動する。
車輪2=かめた!20 円(紫)図形を作る 150 −30 移動する。

星=「かめた!30 歩く 144 右回り」!5 繰り返す(黄色)図形を作る 130 −50 移動する。

車=図形!(屋根)(車体)(車輪1)(車輪2)結合する。
時計=タイマー!作る 0.05 間隔。
時計!30 回数「車!0 −3 移動する」実行。
時計!36 回数「車!10 左回り」実行。
時計!待つ。
車!(星)書く。
時計!30 回数「車!2 歩く 1 左回り。」実行。
時計!30 回数「車!2 歩く 1 右回り。」実行。
時計!80 回数「車!−2 歩く。」実行。

Theme designed by Dining tables
Coder Mothers Day | EZwpthemes |modified by QHM Temps

powered by Quick Homepage Maker 5.0
based on PukiWiki 1.4.7 License is GPL. QHM

最新の更新 RSS  Valid XHTML 1.0 Transitional