休みながら歩く

休みながら歩く

タートルを動かしているときに、「ここで1秒くらい止めたいなあ」と思ったときに、「待つ」という命令があると便利そうです。たとえばプログラムの先頭にこの1行を書いておくと、そのプログラムのタートルは「待つ」という命令を使えるようになります。便利ですね。

タートル:待つ=「|n| タイマー!作る(n)間隔 1 回数「」実行 待つ。自分」。

etn07yPUcv.gif
タイマーで六角形を描くプロウグラム例です。

かめた=タートル!作る。
時計=タイマー!作る 6 回数。
時計!「かめた!100 歩く 1 待つ 60 左回り 1 待つ」実行。

※この機能は将来のバージョンで標準機能に採用される可能性があります。

Theme designed by Dining tables
Coder Mothers Day | EZwpthemes |modified by QHM Temps

powered by Quick Homepage Maker 5.0
based on PukiWiki 1.4.7 License is GPL. QHM

最新の更新 RSS  Valid XHTML 1.0 Transitional