ラズベリーパイでLEDを点滅

ラズベリーパイでLEDを点滅

ドリトルはV2.38からラズベリーパイに対応しました。*1

V2.39からは、スイッチやLEDを接続して入出力を扱うことが可能になる予定です。*2
以下の配線では、「GPIO4」にタクトスイッチを接続し、「GPIO14」にLEDを接続しています。
プログラムを実行すると、画面にスイッチが押されているかどうかが表示され、押されている場合はLEDが光ります。

画像の説明

// 2015-05-19 Kohei Hayashi @ Kanemune Lab.
システム! ”raspberry” 使う。

// 初期化
ラズパイ! 4 入力。
ラズパイ! 4 プルダウン。
ラズパイ! 14 出力。

値=フィールド!作る。
「はい」! の間「 //無限ループ
  値! (ラズパイ! 4 読む) 書く。
  ラズパイ! 14 1 書く。
  ラズパイ! 1 待つ。
」実行。

*1 それ以前もLinux用のドリトルはdolittle.shで実行することは可能でした。
*2 V2.38から可能ですが、マニュアルはV2.39から追加される予定です。

Theme designed by Dining tables
Coder Mothers Day | EZwpthemes |modified by QHM Temps

powered by Quick Homepage Maker 5.0
based on PukiWiki 1.4.7 License is GPL. QHM

最新の更新 RSS  Valid XHTML 1.0 Transitional