図形を次々と生み出す

図形を次々と生み出す

毎回図形を描いてもよいですが、同じ図形を何度も表示するには作ってから見えないようにしておいた図形を複製して使うのが簡単です。「消える」で見えなくなっていた図形は複製することで見えるようになります。以下のサンプルプログラムでは、星を描いてから「消える」で見えなくしておき、使うときに「作る」で複製して利用しています。

d4.gif

かめた=タートル!作る。

// 星を作って消しておく。
星=「かめた!50 歩く 144 右回り」!5 繰り返す(黄色)図形を作る 消える。

// カメが歩いている間は星は見えない。
時計=タイマー!作る 2秒 時間。
時計!「かめた!10 歩く」実行。
時計!待つ。

// 星を複製すると見えるようになる。
星1=星!作る。
時計!「星1!0 10 移動する。」実行。
時計!待つ。

// もう1個複製して動かす。
星2=星!作る。
時計!「星2!10 −10 移動する。」実行。
時計!待つ。

// そういえばタートルが星に変身することもできるのでした。
かめた!"star.png" 変身する。

Theme designed by Dining tables
Coder Mothers Day | EZwpthemes |modified by QHM Temps

powered by Quick Homepage Maker 5.0
based on PukiWiki 1.4.7 License is GPL. QHM

最新の更新 RSS  Valid XHTML 1.0 Transitional