ユーザ用ツール

サイト用ツール


tips_eraseit

特定の相手だけを消す

いくつかの方法があります。用途に応じて使い分けてください。

(方法1) 相手に衝突するオブジェクトではなく、衝突されるオブジェクトに衝突を定義する。 衝突されるオブジェクトの衝突定義には、誰かと衝突したときに自分を消すように書いておきます。 誰かが衝突したら自分を消すので、かめた以外の相手が衝突しても消えてしまいます。

 かめた=タートル!作る。
 かめきち=タートル!作る ペンなし 100 10 位置。
 かめこ=タートル!作る ペンなし 200 0 位置。
 かめこ:衝突=「自分!消える」。
 時計=タイマー!作る。
 時計!「かめた!10 歩く」実行。

(方法2) 衝突した相手を見て、特定のオブジェクトのときだけ相手を消す。 衝突したときに消す相手が増えるとプログラムが複雑になります。

 かめた=タートル!作る。
 かめきち=タートル!作る ペンなし 100 10 位置。
 かめこ=タートル!作る ペンなし 200 0 位置。
 かめた:衝突=「|相手| 「相手==かめこ」!なら「相手!消える」実行」。
 時計=タイマー!作る。
 時計!「かめた!10 歩く」実行。
tips_eraseit.txt · 最終更新: 2018/01/07 11:25 by kanemune