ユーザ用ツール

サイト用ツール


tips_turncenter

図形を中心で回転させる

(2015/5/19)

ドリトルでは、図形は描き始めた点を中心に回転します。 タートルと同じように中心で回転させるには、次のどちらかの方法を使ってください。

(方法1) V2.38からの組図形オブジェクトを使うと、図形を中心で回転できます。 下の例では要素が1個だけの組図形(「三角たち」)を作って回転させています。 「三角」「四角」は今までどおりですが、「三角たち」は中心で回転します。

(方法2) 図形の「turn_center」プロパティに「true」を設定します。 下のプログラムで「三角」にturn_centerを設定すると三角だけが中心で回転します。 「図形」にturn_centerを設定するとすべての図形が中心で回転します。

※ 方法2はV2.38の非公開機能です。今後仕様が変更される可能性があります。

 かめた=タートル!作る。
 四角=「かめた!100 歩く 90 右回り」!4 繰り返す(緑)図形を作る。
 三角=「かめた!100 歩く 120 左回り」!3 繰り返す(青)図形を作る。
 //三角:turn_center=true。
 //図形:turn_center=true。
 時計=タイマー!作る 36 回数。
 時計!「三角!10 左回り」実行。
 三角たち=図形!(三角)結合する。
 時計!「四角!10 右回り」実行。
 時計!「三角たち!10 左回り」実行。
tips_turncenter.txt · 最終更新: 2018/01/07 11:13 by kanemune