ユーザ用ツール

サイト用ツール


tips_updown

上下に繰り返して動かす

(2016/3/1)

同じタイマーオブジェクトに続けて命令を送ると、ひとつの実行が終わってから次の実行が行われます。 この性質を利用すると、「少しずつ上に動く」「少しずつ下に動く」を繰り返して実行することで、オブジェクトを上下や左右に繰り返して動かすことができます。

 かめた=タートル!作る。
 時計=タイマー!作る 5 回数。
 「
 時計!10 回数「かめた!0 5 移動する。」実行。
 時計!10 回数「かめた!0 -5 移動する。」実行。
 」!10 繰り返す。
tips_updown.txt · 最終更新: 2018/01/07 11:22 by kanemune